1. 首页
  2. 常规
  3. rixCloud API TLS 问题
  1. 首页
  2. API
  3. rixCloud API TLS 问题

rixCloud API TLS 问题

部分客户端无法通过 rixCloud API 获取配置时会出现问题,这是因为 rixCloud API 仅支持 TLSv1.2 和 TLSv1.3 Final。Windows 上基于 .NET Framework 开发的应用程序,如果在请求 HTTPS 时未特别修改代码指定 TLS 版本,且要求的最低 .NET Framework 版本低于 4.5,就不会使用 TLSv1.2 来连接。这就将导致部分客户端无法连接到 rixCloud API。

目前仅有 Windows 的客户端受到此影响,其他客户端暂未收到受影响报告。

使用 ShadowsocksR for Windows 的用户,请切换为 rixCloud 提供的版本,rixCloud 的版本要求 .NET Framework 4.7 及以上版本,最新版本的 Windows 10 应当已经自带。其他任何修改版的 SSR 客户端应当都不支持,请勿使用。

使用 SSTap 的用户,由于 SSTap 并不是开放源代码程序,因此 rixCloud 无法对其进行修改,目前暂时没有解决方案。

更新 十一月 16, 2018

相关文章

发表评论